Aces of The Luftwaffe Squadron

(Like and sharing game for your friends)

GAME NAME
Aces of The Luftwaffe Squadron
LANGUAGE
Multi
RELEASE
2018
GENRE
Action

Download

Link Download

Note: Game for PS4 – not use PS3 – Test with 6.72

CUSA08164 – EUR

Thank @African

Game : Zippy1FileOnedrive

Update 1.05 : Lets1File

Update 1.05 (Fix 5.05) : Download

DLC : Lets1File

Password: downloadgameps3.com

Audio languages: English.
Subtitle languages: English, German, Italian, French and Spanish.

Guide DownloadTool Download )

Link Mirror

Note: Game for PS4 – not use PS3 – Test with 6.72

CUSA08164 – EUR

Thank @dorukhan

Game : Zippy

Update 1.05 : Lets1File

Update 1.05 (Fix 5.05) : Download

DLC : Lets1File

Password: downloadgameps3.com

Audio languages: English.
Subtitle languages: English, German, Italian, French and Spanish.

Guide DownloadTool Download )

Aces of the Luftwaffe: Squadron is an Action game, developed and published by HandyGames, which was released in 2018.

0 0 vote
Article Rating
guest
17 Comments
Newest
Oldest Most Voted
Inline Feedbacks
View all comments
opoisso893

Aces of the Luftwaffe Squadron – CUSA08164 v1.05 Backport 5.05:
aHR0cHM6Ly8xZmljaGllci5jb20vP2cxdXlpaXZsZTdnZXlzNWMxMXR3JmFmPTI4OTk1MDc=
Works with Duplex release. Repackage for other release.

robe36

can someone please fix the game + update + 5.05 backport? Both links contain unmarried or corrupt 1.05 updates that don’t match the game, so dont install properly. The backport needs redone as well once the base and update agree with each other. I tried duxa tool on both and they both failed, so it need to be remarried manually

Elías

Gracias por compartir pero el juego no funicona en 6.72.
La actualización da error al instalar.
Si ponemos el juego baseno funciona y juego base con dlc te saca del juego y tampoco te deja comenzar.
Si alguien pudiera compartir una versión que funcione le estaría muy agradecido.
Saludos.

l3tsplayPS4

Update 1.05 + DLC NOT WORKING for BOTH Base Game Duplex & DarkSoftware.

john

i cant install the update 1.05 file for 6.72.
i only can install game and dlc on my ps4 slim with 6.72

l3tsplayPS4_0n_672

and if you try to run base+dlc=game error

john

yes, base + dlc in this combination dont work, game crashes 🙁
maybe it works from ?

john

the version from the turkey forum (hako) works perfekt: game, update and patch

l3tsplayPS4_0n_672

can someone reupload a hako release of this game. TIA

Ghost hunter

the Update file is corrupted

Arie

Update 1.05 for 6.72 is Corrupted

jackson

al juego le faltan archivos, no se puede descargar porque pide otro volumen..

brad

the backport of this game please

l3tsplayPS4

love this kind of games

Raiden80

Thanks for the important information.

Tags: